Switching

Expand all | Collapse all

vQFX MC-LAG not working!

Jump to Best Answer
  • 1.  vQFX MC-LAG not working!

    Posted 10-06-2017 03:24

    tried a few versions, and I can't get the data-plane to work i.e arp-request gets to either of the MC-LAG pair but they never reply to the host, also the "show iccp detail" keeps bouncing from up to down.

     

    I'm using the two vm RE/PFE combinations, other functions some basic ones seem to work ok, I checked with Juniper SE he mentioned it works on release

    15.1X53-D63.9

     

    but I can't get it to work!

     

    outputs are below:

     

    root@vQFX-RE1# run show iccp detail    
    
    Redundancy Group Information for peer 10.19.211.2
      TCP Connection       : In progress
      Liveliness Detection : Up
      Redundancy Group ID          Status
        1                           Down 
    
    root@vQFX-RE1# run show iccp detail    
    
    Redundancy Group Information for peer 10.19.211.2
      TCP Connection       : Established
      Liveliness Detection : Up
      Redundancy Group ID          Status
        1                           Up   
    
    
    root@vQFX-RE1# run show version 
    fpc0:
    --------------------------------------------------------------------------
    Hostname: vQFX-RE1
    Model: vqfx-10000
    Junos: 15.1X53-D63.9
    
    root@vQFX-RE2# run show version 
    fpc0:
    --------------------------------------------------------------------------
    Hostname: vQFX-RE2
    Model: vqfx-10000
    Junos: 15.1X53-D63.9
    
    
    vQFX1
    set chassis aggregated-devices ethernet device-count 10
    set interfaces xe-0/0/0 ether-options 802.3ad ae0
    set interfaces xe-0/0/1 ether-options 802.3ad ae0
    set interfaces xe-0/0/2 ether-options 802.3ad ae1
    set interfaces xe-0/0/4 ether-options 802.3ad ae2
    set interfaces xe-0/0/6 ether-options 802.3ad ae2
    set interfaces ae0 description ICCP-Link
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 10.19.211.1/30
    set interfaces ae1 description To-IOL-SW
    set interfaces ae1 vlan-tagging
    set interfaces ae1 multi-chassis-protection 10.19.211.2
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:02
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 2
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control active
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan members all
    set interfaces ae2 description ICP-PL
    set interfaces ae2 flexible-vlan-tagging
    set interfaces ae2 encapsulation flexible-ethernet-services
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan members all
    set interfaces em1 unit 0 family inet address 169.254.0.2/24
    set interfaces irb unit 200 family inet address 10.14.200.30/24
    set interfaces irb unit 201 family inet address 10.14.201.30/24
    set multi-chassis multi-chassis-protection 10.19.211.2 interface ae0
    set forwarding-options storm-control-profiles default all
    set protocols iccp local-ip-addr 10.19.211.1
    set protocols iccp peer 10.19.211.2 redundancy-group-id-list 1
    set protocols iccp peer 10.19.211.2 liveness-detection minimum-interval 150
    set protocols iccp peer 10.19.211.2 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.2 liveness-detection multiplier 3
    set protocols iccp peer 10.19.211.2 authentication-key "$9$RMFcrvxNboJDWLJDikTQEcy"
    set protocols igmp-snooping vlan default
    set protocols vstp interface ae1
    set protocols vstp vlan 1 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 1 interface ae1
    set protocols vstp vlan 200 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 200 interface ae1
    set protocols vstp vlan 201 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 201 interface ae1
    set protocols vstp vlan all bridge-priority 0
    set protocols vstp vlan all interface ae1
    set switch-options service-id 1
    set vlans default vlan-id 1
    set vlans v-200 vlan-id 200
    set vlans v-200 l3-interface irb.200
    set vlans v-200 mcae-mac-synchronize
    set vlans v-201 vlan-id 201
    set vlans v-201 l3-interface irb.201
    set vlans v-201 mcae-mac-synchronize
    
    
    
    vQFX2
    set chassis aggregated-devices ethernet device-count 10
    set interfaces xe-0/0/0 ether-options 802.3ad ae0
    set interfaces xe-0/0/1 ether-options 802.3ad ae0
    set interfaces xe-0/0/2 ether-options 802.3ad ae1
    set interfaces xe-0/0/4 ether-options 802.3ad ae2
    set interfaces xe-0/0/6 ether-options 802.3ad ae2
    set interfaces ae0 description ICCP-Link
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 10.19.211.2/30
    set interfaces ae1 description To-IOL-SW
    set interfaces ae1 vlan-tagging
    set interfaces ae1 multi-chassis-protection 10.19.211.1
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:02
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 2
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control standby
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae1 unit 0 family ethernet-switching vlan members all
    set interfaces ae2 description ICP-PL
    set interfaces ae2 flexible-vlan-tagging
    set interfaces ae2 encapsulation flexible-ethernet-services
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae2 unit 0 family ethernet-switching vlan members all
    set interfaces em1 unit 0 family inet address 169.254.0.2/24
    set interfaces irb unit 200 family inet address 10.14.200.30/24
    set interfaces irb unit 201 family inet address 10.14.201.30/24
    set multi-chassis multi-chassis-protection 10.19.211.1 interface ae0
    set forwarding-options storm-control-profiles default all
    set protocols iccp local-ip-addr 10.19.211.2
    set protocols iccp peer 10.19.211.1 redundancy-group-id-list 1
    set protocols iccp peer 10.19.211.1 liveness-detection minimum-interval 150
    set protocols iccp peer 10.19.211.1 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.1 liveness-detection multiplier 3
    set protocols iccp peer 10.19.211.1 authentication-key "$9$RMFcrvxNboJDWLJDikTQEcy"
    set protocols igmp-snooping vlan default
    set protocols vstp interface ae1
    set protocols vstp vlan 1 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 1 interface ae1
    set protocols vstp vlan 200 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 200 interface ae1
    set protocols vstp vlan 201 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 201 interface ae1
    set protocols vstp vlan all bridge-priority 0
    set protocols vstp vlan all interface ae1
    set switch-options service-id 1
    set vlans default vlan-id 1
    set vlans v-200 vlan-id 200
    set vlans v-200 l3-interface irb.200
    set vlans v-200 mcae-mac-synchronize
    set vlans v-201 vlan-id 201
    set vlans v-201 l3-interface irb.201
    set vlans v-201 mcae-mac-synchronize


  • 2.  RE: vQFX MC-LAG not working!

     
    Posted 10-06-2017 05:57

    60ms BFD interval is really short, can you set to 500 or 1000ms?

     

    VQFX1

    del protocols iccp peer 10.19.211.2 liveness-detection minimum-interval 150
    del protocols iccp peer 10.19.211.2 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.2 liveness-detection minimum-interval 1000
    

    VQFX2

    del protocols iccp peer 10.19.211.1 liveness-detection minimum-interval 150
    del protocols iccp peer 10.19.211.1 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.1 liveness-detection minimum-interval 1000


  • 3.  RE: vQFX MC-LAG not working!
    Best Answer

    Posted 10-06-2017 14:12

    managed to figure this out, i needed static arp entries per host for it to work of course not very scalable 😞

     

    but enough for tests.

     

    set interfaces irb unit 200 family inet address 10.14.200.30/24 arp 10.14.200.103 l2-interface ae1.0
    set interfaces irb unit 200 family inet address 10.14.200.30/24 arp 10.14.200.103 mac aa:bb:cc:01:70:00
    
    set interfaces irb unit 201 family inet address 10.14.201.30/24 arp 10.14.201.103 l2-interface ae1.0
    set interfaces irb unit 201 family inet address 10.14.201.30/24 arp 10.14.201.103 mac aa:bb:cc:00:20:00


  • 4.  RE: vQFX MC-LAG not working!

     
    Posted 10-07-2017 06:34

    That would not cause ICCP to bounce, so you may still have that issue. The static arp issue is an unfortunate requirement, more details here:

     

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB27865



  • 5.  RE: vQFX MC-LAG not working!

    Posted 10-08-2017 13:14

    I didn't say it made iccp bounce (that was caused by anycast vxlan vtep configuration) which when removed the show iccp detail stabalised.

     

    here in the case of vQFX hosts we're unable to ping their default gateway i did packet captures and the PFE/RE received the arp packets but they do not update their arp-cache for some bizzare reason.

     

    I'm glad you sent me this link but really have Juniper not fixed this for the physical MX platforms?

     

    I tested this on vMX 14.1 and 17.1 - no static arp entries are required so this problem is related to the vQFX per what I posted above.