Switching

Expand all | Collapse all

Spanning Tree on ELS EX switches

Jump to Best Answer
  • 1.  Spanning Tree on ELS EX switches

     
    Posted 08-22-2017 08:08

    Hi,

     

    I have been testing the "bpdu-block-on-edge" command on an EX3400 on 15.1X53-D56. I have noticed that the recovery timeout appears to now be configured on the interface rather than globally.

     

    When I delibrately loop two ports the port is disabled.

     

    xxx> show spanning-tree interface ge-0/0/2

    Spanning tree interface parameters for instance 0

    Interface Port ID Designated Designated Port State Role
    port ID bridge ID Cost
    ge-0/0/2 128:490 128:490 4096.e8b6c2663b61 20000 BLK DIS (Bpdu-Incon)

     

    But the port never recovers.

     

    Also I can not find a command to clear it manually!

     

    xxx> clear ethernet-switching recovery-timeout interface ge-0/0/2

     

    xxx> show spanning-tree interface ge-0/0/2

    Spanning tree interface parameters for instance 0

    Interface Port ID Designated Designated Port State Role
    port ID bridge ID Cost
    ge-0/0/2 128:490 128:490 4096.e8b6c2663b61 20000 BLK DIS (Bpdu-Incon)

     

    Please could anyone help?



  • 2.  RE: Spanning Tree on ELS EX switches

     
    Posted 08-22-2017 08:27

    Try

     

    [edit protocols layer2-contorl bpdu-block interface interface-name]
    user@switch# set disable-timeout seconds

    and

    user@switch> clear error bpdu interface (all | interface-name)

    Regards, Wojtek



  • 3.  RE: Spanning Tree on ELS EX switches

     
    Posted 08-22-2017 10:38

    Hi Wdudys,

     

    The manual clear works! thanks.

     

    However, I am still having an issue with the auto recovery. I do not seem to be getting the same options as you:

     

    {master:0}[edit protocols layer2-control bpdu-block interface ge-0/0/2]
    lab@xxx# set ?
    Possible completions:
    + apply-groups Groups from which to inherit configuration data
    + apply-groups-except Don't inherit configuration data from these groups
    disable Disable bpdu-block on a port
    drop Drop xSTP BPDUs
    {master:0}[edit protocols layer2-control bpdu-block interface ge-0/0/2]
    lab@xxx# set disable ?
    Possible completions:
    <[Enter]> Execute this command
    + apply-groups Groups from which to inherit configuration data
    + apply-groups-except Don't inherit configuration data from these groups
    drop Drop xSTP BPDUs
    | Pipe through a command

     

    As you can see, there is no "disable-timeout" option.



  • 4.  RE: Spanning Tree on ELS EX switches
    Best Answer

     
    Posted 08-22-2017 15:57

    How about a global setting?

     

    set protocols layer2-control bpdu-block disable-timeout

    Regards, Wojtek