Switching

Expand all | Collapse all

EX4300 XSTP : Interface error after Junos upgrade

Jump to Best Answer
  • 1.  EX4300 XSTP : Interface error after Junos upgrade

    Posted 11-03-2019 20:27

    Hi,

    Recently we have upgrade Junos on EX4300 virtual chassis. After upgrade we saw below error.

     

    speed 100m;
    ##
    ## Warning: statement ignored: unsupported platform (ex4300-48p)
    ##
    link-mode full-duplex;
    unit 0 {
    family inet {
    address 10.10.1.20/30;

     

    I tried to delete --> link-mode full-duplex; but getting below error. Please suggest how to fix it.

     

    Core-Switch# run show configuration |display set |match ge-0/0/45
    set interfaces ge-0/0/45 speed 100m
    set interfaces ge-0/0/45 link-mode full-duplex
    set interfaces ge-0/0/45 unit 0 family inet address 10.10.1.20/30
    set protocols ospf area 0.0.0.0 interface ge-0/0/45.0 bfd-liveness-detection minimum-interval 200
    set protocols ospf area 0.0.0.0 interface ge-0/0/45.0 bfd-liveness-detection multiplier 3

    {master:0}[edit]
    Core-Switch# delete interfaces ge-0/0/45 link-mode full-duplex

    {master:0}[edit]
    Core-Switch# commit check
    [edit protocols]
    'ospf'
    warning: requires 'ospf2' license
    [edit protocols ospf area 0.0.0.0 interface ge-0/0/46.0]
    'bfd-liveness-detection'
    warning: requires 'bfd-liveness-detection' license
    [edit protocols rstp]
    'interface'
    XSTP : Interface ge-0/0/45 is not enabled for Ethernet Switching
    error: configuration check-out failed

     

    Regards,

    Np


    #EX4300


  • 2.  RE: EX4300 XSTP : Interface error after Junos upgrade

     
    Posted 11-03-2019 21:09

     Hi Target,

     

    Looks like you have the interface enabled under RSTP (default config when interface has family ethernet-switching).  Please delete this if you need to make the interface family inet i.e.:

     

    delete protocols rstp interface ge-0/0/45

     

    See these for details:
    https://www.juniper.net/documentation/en_US/junos13.2/topics/task/configuration/ex-series-gigabit-interfaces-cli-els.html

    https://www.juniper.net/documentation/en_US/junos13.2/topics/task/configuration/getting-started-els.html

     

    Hope this helps.

     

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 3.  RE: EX4300 XSTP : Interface error after Junos upgrade

     
    Posted 11-03-2019 21:10

    RSTP operates on layer 2 interfaces, and ge-0/0/45 is configured as layer 3. You will need to exclude this interface from the RSTP configuration. Junos versions > 14 are more strict with xSTP interface validation.



  • 4.  RE: EX4300 XSTP : Interface error after Junos upgrade

    Posted 11-03-2019 22:34

    Hi,

    Please see below "statement not found warning" after --> delete protocols rstp interface ge-0/0/45

    as well in show |compare their is no change in confirg.

     

    Core-Switch# run show configuration |display set |match ge-0/0/45

    set interfaces ge-0/0/45 speed 100m
    set interfaces ge-0/0/45 link-mode full-duplex
    set interfaces ge-0/0/45 unit 0 family inet address 10.10.1.20/30
    set protocols ospf area 0.0.0.0 interface ge-0/0/45.0 bfd-liveness-detection minimum-interval 200
    set protocols ospf area 0.0.0.0 interface ge-0/0/45.0 bfd-liveness-detection multiplier 3

    {master:0}[edit]
    Core-Switch# delete protocols rstp interface ge-0/0/45
    warning: statement not found

    {master:0}[edit]
    Core-Switch# show |compare

    {master:0}[edit]



  • 5.  RE: EX4300 XSTP : Interface error after Junos upgrade

    Posted 11-03-2019 22:42

    RSTP config on switch

     

    Core-switch# run show configuration |display set |match rstp
    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-2/0/0 to ge-2/0/47
    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-3/0/0 to ge-3/0/47
    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-4/0/0 to ge-4/0/47
    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-0/0/5 to ge-0/0/47
    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-1/0/5 to ge-1/0/47
    set protocols rstp bridge-priority 20k
    set protocols rstp interface ALL_RSTP_ENABLE edge
    set protocols rstp interface ALL_RSTP_ENABLE no-root-port



  • 6.  RE: EX4300 XSTP : Interface error after Junos upgrade
    Best Answer

     
    Posted 11-04-2019 02:02

    Hi Target,

     

    You will need to take the interface ge-0/0/45 out of the group config.

     

    delete interfaces interface-range ALL_RSTP_ENABLE member-range ge-0/0/5 to ge-0/0/47

    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-0/0/5 to ge-0/0/44

    set interfaces interface-range ALL_RSTP_ENABLE member-range ge-0/0/46 to ge-0/0/47



  • 7.  RE: EX4300 XSTP : Interface error after Junos upgrade

     
    Posted 11-04-2019 06:09