Switching

Expand all | Collapse all

EX4300 error

  • 1.  EX4300 error

    Posted 03-16-2017 14:11

    Anyone have any insight into what this error means? it is happeneing on several 4300 VC's and not on the rest.

     

    CHK pfex: PFE-BCM-L2,pfe_bcm_multicast_hw_create(),94:sw_mc_idx: 0x16, bcm_mc_idx: 0x2000016 new_mcast_nh(TRUE) glob-mc-idx: 0x2000016



  • 2.  RE: EX4300 error

     
    Posted 03-16-2017 22:26

    Hello,

     

    Which Junos version you are running on affected EX4300?

     

    Regarding the meaning of the log:

     

    The mentioned log message is printed whenever PFE receives a message from RE to create a new mc-idx in HW. This log message is safe to ignore as it is just a information printed in logs. It does not indicate any error.

     

    Regards,

     

    Rushi



  • 3.  RE: EX4300 error

     
    Posted 03-16-2017 22:32

    Hi Folks,

    I remember these are harmless error logs getting generated after adding the pim/multicast routes.

    As a workaround, use below filter configuration to suppress the log message:

     

    root#set system syslog file messages match "!(.*pfe_bcm_multicast_hw_create().*)"

     

     



  • 4.  RE: EX4300 error

    Posted 03-19-2017 20:59
    The below log messages are printed whenever PFE receives a message from RE to create a new mc-idx in HW.
    
    pfex: %USER-3: PFE-BCM-L2,pfe_bcm_multicast_hw_create(),79:sw_mc_idx: 0x1, bcm_mc_idx:0x2000001 new_mcast_nh(FALSE) glob-mc-idx:0x2000001
    pfex: %USER-3: PFE-BCM-L2,pfe_bcm_multicast_hw_create(),62:sw_mc_idx: 0x1, new_mcast_nh(FALSE)
    
    These log messages are harmless and can be ignored
    Also as a workaround if the log level of emergency is enabled instead of default (error), these messages will be suppressed from logging

     

     https://prsearch.juniper.net/PR984891

     

    Thanks

    Partha



  • 5.  RE: EX4300 error

     
    Posted 11-02-2018 02:54

    Hi Team,

     

    I am seeing errors like these on my EX4300, this has thus caused a spike in CPU utilisation for pfex_junos process around 30%. Request your help in understanding these messages and how to get rid of these.

     

    Does the restart of "pfex_junos" solve this issue.

     

    Oct 21 18:30:05 test_host pfex: Scheduler Oinker
    Oct 21 18:30:05 test_host pfex: Frame 00: sp = 0x03bc4230, pc = 0x018466b4
    Oct 21 18:30:05 test_host pfex: Frame 01: sp = 0x03bc4248, pc = 0x0180edf0
    Oct 21 18:30:05 test_host pfex: Frame 02: sp = 0x03bc42a0, pc = 0x018108ac
    Oct 21 18:30:05 test_host pfex: Frame 03: sp = 0x03bc42d0, pc = 0x0184bcf8
    Oct 21 18:30:05 test_host pfex: Frame 04: sp = 0x03bc4318, pc = 0x018103a4
    Oct 21 18:30:05 test_host pfex: IPC Socket is closed
    Oct 21 18:30:05 test_host pfex: BULKGET: Master socket closed
    Oct 21 18:30:05 test_host pfex: BULKGET disconnected: BULKGET socket closed abruptly
    Oct 21 18:30:05 test_host pfex: Bulkget manager reconnection succeeded after 1 tries
    Oct 21 18:30:05 test_host pfex: BULKGET master RE reconnection made
    Oct 21 18:37:00 test_host pfex: uncached heap start 0x234db000 0x78000000 size 0x8000000 status 0
    Oct 21 18:37:00 test_host pfex: dma desc heap start 0x2a4db000 end 0x2b4db000 status 0
    Oct 21 18:37:01 test_host pfex: PFEBM: BEM0
    Oct 21 18:37:01 test_host pfex: BME0 created
    Oct 21 18:37:02 test_host pfex: AN-INIT: an_gencfg_init Analytics gencfg init done
    Oct 21 18:37:02 test_host pfex: L2ALM: failed to connect to Master
    Oct 21 18:37:02 test_host pfex: Error in bcm_switch_control_set(Egress) : Reason Invalid unit
    Oct 21 18:37:02 test_host pfex: sflow socket connect failed (no route to host)
    Oct 21 18:37:02 test_host pfex: mojito_get_pci_base_addr: BCM device id 0xb648
    Oct 21 18:37:02 test_host pfex: cmex_asic_init: PCI Base address 0xc0000000 devid 0xb648 revid 0x11
    Oct 21 18:37:04 test_host pfex: TimeSync PLL not locked on unit 0 status = 0x00000102
    Oct 21 18:37:04 test_host pfex: BroadSync PLL not locked on unit 0 status = 0x00000102
    Oct 21 18:37:10 test_host pfex: Frame 00: sp = 0x04520a90, pc = 0x01849480
    Oct 21 18:37:10 test_host pfex: Frame 01: sp = 0x04520aa8, pc = 0x0180f714
    Oct 21 18:37:10 test_host pfex: Frame 02: sp = 0x04520b00, pc = 0x018111d0
    Oct 21 18:37:10 test_host pfex: Frame 03: sp = 0x04520b30, pc = 0x01824ce0
    Oct 21 18:37:10 test_host pfex: Frame 04: sp = 0x04520c08, pc = 0x01821e08
    Oct 21 18:37:10 test_host pfex: Frame 05: sp = 0x04520c50, pc = 0x0180a668
    Oct 21 18:37:10 test_host pfex: Frame 06: sp = 0x04520c78, pc = 0x01810cc8
    Oct 21 18:37:24 test_host pfex: vlan 2 mac_learn 0 get failed (-4-Invalid parameter)
    Oct 21 18:37:24 test_host pfex: learn disable failed(1000) on egress default vlan
    Oct 21 18:37:26 test_host pfex: PFE-BCM-L2,pfe_bcm_l2_dev_init(),398:Egress default VLAN creation failed (Entry exists:-8)
    Oct 21 18:37:26 test_host pfex: cmex_poe_init Unsupported board id 2908

    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: Error getting IFD info for PFE 0 Port 4
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC] ex_bcm_linkscan_handler: Link 5 DOWN
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: No IFD available for PFE 0 port 5
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: Error getting IFD info for PFE 0 Port 5
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC] ex_bcm_linkscan_handler: Link 6 DOWN
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: No IFD available for PFE 0 port 6
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: Error getting IFD info for PFE 0 Port 6
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC] ex_bcm_linkscan_handler: Link 7 DOWN
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: No IFD available for PFE 0 port 7
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC]: Error getting IFD info for PFE 0 Port 7
    Oct 21 18:37:26 test_host pfex: [EX-BCM PIC] ex_bcm_linkscan_handler: Link 8 DOWN

     

     

    //Nexon



  • 6.  RE: EX4300 error

     
    Posted 11-28-2018 11:05

    I found the reason for the pfex spike, one of the QSFP on the rear of the device was not reading the EEPROM values. "pfex" was trying to read the values again and again causing spike, reseating the QSFP resolved the issue.

     

    //Nexon