Expand all | Collapse all

Inband Management on EX3300

Jump to Best Answer
  • 1.  Inband Management on EX3300

    Posted 01-13-2017 07:25
      |   view attached

    Hi All,

    I'm a Juniper n00b, so bare with me. 🙂

    I'm setting up inband management and unable to hit the mgmt interface (am connected to the switch directly)


    I've assigned an IP to a new MGMT vlan;
    set interface vlan.10 family inet address
    set vlan mgmt l3-interface vlan.10
    set system services web-management http interface vlan.10


    Unsure what is missing here.
    Attached is config.


    Any help appreciated.


    conf.zip   1 KB 1 version

  • 2.  RE: Inband Management on EX3300

    Posted 01-13-2017 07:53



    i think your problem is that you have created a vlan "MGMT" with vlan-id 10 and then another vlan named "mgmt" (lower-case) which you have attached the vlan.10 interface:


    vlans {
        MGMT {
            vlan-id 10;
        mgmt {
            l3-interface vlan.10;

    Try to delete "vlan mgmt" and attach l3-interface to vlan MGMT 🙂

  • 3.  RE: Inband Management on EX3300

    Posted 01-13-2017 08:29

    Corrected but no luck unforunately.

    I can't ping the interface from the switch itself either. :S


    Updated conf:

    me0 {
    unit 0 {
    family inet {
    vlan {
    unit 10 {
    family inet {


    vlans {
    mgmt {
    vlan-id 10;
    l3-interface vlan.10;
    vlan-guest {
    vlan-id 4001;
    vlan-temp {
    vlan-id 4000;

  • 4.  RE: Inband Management on EX3300

    Posted 01-13-2017 08:39

    What physical interface/port are you on?  You need to add interface into the VLAN, or associated VLAN to interface, Junos allows for both options.  If this correct and still not working, then:


    Does your PC/device see the switch IP and MAC in it's arp table?  Something like arp -a I think works on windows, I know it works on my MAC.  I assume you are seeing link on the interface/port, yes?

  • 5.  RE: Inband Management on EX3300
    Best Answer

    Posted 01-13-2017 08:50

    Ok, you cannot reach vlan.10 via me0.0. I expect that you via the management network ( connected to me0.0 has a static route for towards Having a /32 route on a vlan interface does not make much sense 🙂


    This is not how you should do inband management. You should place the RVI (vlan.10) in your management vlan and define an IP in that subnet. I guess this is So move the me0.0 IP to vlan.10 and change to different vlan if it makes sense.


    But! May I guess? You are trying to do inband management on your EX3300 virtual-chassis to avoid loosing management access when the routing-engine is moved to another switch.


    If i'm correct you can instead look into using the virtual management interface (vme) instead. This features provides a shared management IP for the virtual-chassis which moves to the active routing-engine. You just need to cable all management-interfaces to your management-infrastructure.


    More info: https://kb.juniper.net/InfoCenter/index?page=content&id=KB25724&smlogin=true&actp=search


    Hope this information helps modify your config to fit your need.

  • 6.  RE: Inband Management on EX3300

    Posted 01-17-2017 02:17

    Thanks. Adjusted config and working now.

  • 7.  RE: Inband Management on EX3300

    Posted 01-23-2019 20:44

    Can you share the adjusted, working config?