Switching

Expand all | Collapse all

QinQ QFX and EX

Jump to Best Answer
  • 1.  QinQ QFX and EX

    Posted 06-17-2017 09:57

    Hello Guys,

     

    I'm trying to configure a QinQ vlan from a EX4550 to a QFX3550. I have checked all the forums and corrected any possible mistake on the 4550, like the ethertype thing, but it is still not working.

     

    This is my conf:

     

    EX4550x2 --- EX4550x1 -- QFX3550x1

     

    this is the configuration:

     

    EX4550x2:

     

    vlan100 {

        vlan-id 100;

        dot1q-tunneling {

            customer-vlans 1-4094;

        }

    }

     

    interfaces xe-1/0/5 {

    description "DLX5_SERV + MGMT NIC2";

    mtu 9216;

    unit 0 {

        family ethernet-switching {

            port-mode access;

            vlan {

                members vlan100;

            }

        }

    }

     

     

    ae1 {

    mtu 9216;

    aggregated-ether-options {

        minimum-links 1;

        link-speed 10g;

        lacp {

            active;

            periodic fast;

        }

    }

    unit 0 {

        family ethernet-switching {

            port-mode trunk;

            vlan {

                members vlan100

            }

        }

    }

     

    ezequiel@EX4550x2> show configuration ethernet-switching-options 

    dot1q-tunneling {

        ether-type 0x8100;

    }

     

     

    EX4550x1:

     

    ezequiel@EX4550x1> show configuration interfaces xe-0/0/27  <<PORT FACING QFX3550x1

    description "UPLINK COBOGWBPQX3500x3 PUERTO XE-0/0/0";

    unit 0 {

        family ethernet-switching {

            port-mode trunk;

            vlan {

                members vlan100;

            }

        }

    }

     

     

     

     

    ae0  {

    mtu 9216;

    aggregated-ether-options {

        minimum-links 1;

        link-speed 10g;

        lacp {

            active;

            periodic fast;

        }

    }

    unit 0 {

        family ethernet-switching {

            port-mode trunk;

            vlan {

                members vlan100

            }

        }

    }

     

    QFX3550:

    root@QFX3550x1> show configuration vlans vlan100  

    interface xe-0/0/10.100;

    interface xe-0/0/11.100;

    interface xe-1/0/0.100;

    interface xe-1/0/10.100;

     

     

    oot@QFX3550x1> show configuration interfaces xe-0/0/10           <<CE PORT

    flexible-vlan-tagging;

    native-vlan-id 100;

    encapsulation extended-vlan-bridge;

    unit 100 {

        vlan-id-list 1-4094;

        input-vlan-map push;

        output-vlan-map pop;

    }

     

    root@QFX3550x1> show configuration interfaces xe-1/0/0   << PORT FACING EX4550x1 (trunk)

    flexible-vlan-tagging;

    encapsulation extended-vlan-bridge;

    unit 100 {

        vlan-id 100;

    }

     

    I see mac addresses from customers in both EX4550 but not in the QFX. Also I have mac addresses in the QFX but they are not passing to the EX. I guess the problem is on trunk QFX/EX configuration but I dont know how to fix it. I have tried multiple configurations,  flexible-vlan/vlan-id, standard trunk with vlan members but none of them seem to be working.

     

     

    Txs

    Ezeq.

     

     

     

     

     



  • 2.  RE: QinQ QFX and EX
    Best Answer

    Posted 06-17-2017 19:29

    HI

     

    This is one sample config which I have tested see if this helps

     

    QinQ ELS Configs

    +------------------+         +------------------+         +--------------------+         +--------------------+
    |  EX2200          +---------+  QFX-5100        +---------+  EX3300            +---------+  EX2200            |
    |                  |         |                  |         |                    |         |                    |
    +----------------0/1/0      0/0/0-------------0/0/23     0/1/0-----------------0/0/0    0/1/0-----------------+
                                 +

    EX2200

    root@2200-Left> show configuration vlans
    v200 {
        vlan-id 200;
        interface {
            ge-0/1/0.0;
        }
        l3-interface vlan.200;
    }
    vlans {
        vlan-id 100;
        interface {
            ge-0/0/0.0;
            ge-0/1/0.0;
        }
    }

    {master:0}
    root@2200-Left> show configuration interfaces vlan.200
    family inet {
        address 20.20.20.1/24;
    }

    QFX5100

    root@5100# show interfaces ge-0/0/0
    flexible-vlan-tagging;
    encapsulation extended-vlan-bridge;
    unit 4000 {
        vlan-id-list 100-200;
        input-vlan-map push;
        output-vlan-map pop;
    }

    {master:0}[edit]
    root@5100# show interfaces ge-0/0/23
    flexible-vlan-tagging;
    encapsulation extended-vlan-bridge;
    unit 4000 {
        vlan-id 4000;
    }

    {master:0}[edit]
    root@5100# show vlans
    Svlan {
        interface ge-0/0/23.4000;
        interface ge-0/0/0.4000;
    }

    EX3300

    "root@3300# show interfaces ge-0/1/0
    unit 0 {
        family ethernet-switching {
            port-mode trunk;
            vlan {
                members 4000;
            }
        }
    }

    {master:0}[edit]
    root@3300# show interfaces ge-0/0/0    
    unit 0 {
        family ethernet-switching {
            port-mode access;
            vlan {
                members 4000;
            }
        }
    }

    {master:0}[edit]
    root@3300# show vlans
    Svlan {
        vlan-id 4000;
        ##
        ## Warning: requires 'dot1q-tunneling' license
        ##
        dot1q-tunneling {
            customer-vlans 100 200;
            layer2-protocol-tunneling {
                all;
            }
        }
    }

    {master:0}[edit]
    root@3300# show ethernet-switching-options
    dot1q-tunneling {
        ether-type 0x8100;
    }
    storm-control {
        interface all;
    }

    EX2200

    root@2200-Right# show interfaces ge-0/1/0
    unit 0 {
        family ethernet-switching {
            port-mode trunk;
            vlan {
                members all;
            }
        }
    }

    [edit]
    root@2200-Right# show vlans
    v200 {
        vlan-id 200;
        l3-interface vlan.200;
    }

    [edit]
    root@2200-Right# show interfaces vlan.200
    family inet {
        address 20.20.20.2/24;
    }


    QinQ with PC directly connected to PE Devices.

         +---------------+           +-----------------+         +------------------+        +-----------------+
         |               |           |                 |         |                  |        |                 |
         |          0/0/0+-----------+0/0/1        0/0/0---------+0/0/0        0/0/1+--------+0/0/0            |
         +---------------+           +-----------------+         +------------------+        +-----------------+
              2200-A                       4300-A                      4300-B                      2200-B
     
    0/0/0-30.30.30.1                  svlan 4000                   svlan 4000                     0/0/0-30.30.30.2
                                      cvlan 100 200                cvlan 100 200                  


    2200-A

    set interfaces ge-0/0/0 unit 0 family inet address 30.30.30.1/24
    set interfaces vlan unit 100 family inet address 10.10.10.1/24
    set interfaces vlan unit 200 family inet address 20.20.20.1/24
    set ethernet-switching-options storm-control interface all
    set vlans v100 vlan-id 100
    set vlans v100 interface ge-0/0/0.0
    set vlans v100 l3-interface vlan.100
    set vlans v200 vlan-id 200
    set vlans v200 interface ge-0/0/0.0
    set vlans v200 l3-interface vlan.200
                                  
    4300-A

    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 encapsulation extended-vlan-bridge
    set interfaces ge-0/0/0 unit 4000 vlan-id 4000
    set interfaces ge-0/0/1 flexible-vlan-tagging
    set interfaces ge-0/0/1 native-vlan-id 50
    set interfaces ge-0/0/1 encapsulation extended-vlan-bridge
    set interfaces ge-0/0/1 unit 4000 vlan-id-list 50
    set interfaces ge-0/0/1 unit 4000 vlan-id-list 100-200
    set interfaces ge-0/0/1 unit 4000 input-vlan-map push
    set interfaces ge-0/0/1 unit 4000 output-vlan-map pop
    set vlans Svlan interface ge-0/0/0.4000
    set vlans Svlan interface ge-0/0/1.4000
    set vlans v50 vlan-id 50

    4300-B

    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 encapsulation extended-vlan-bridge
    set interfaces ge-0/0/0 unit 4000 vlan-id 4000
    set interfaces ge-0/0/1 flexible-vlan-tagging
    set interfaces ge-0/0/1 native-vlan-id 50
    set interfaces ge-0/0/1 encapsulation extended-vlan-bridge
    set interfaces ge-0/0/1 unit 4000 vlan-id-list 50
    set interfaces ge-0/0/1 unit 4000 vlan-id-list 100-200
    set interfaces ge-0/0/1 unit 4000 input-vlan-map push
    set interfaces ge-0/0/1 unit 4000 output-vlan-map pop
    set vlans Svlan interface ge-0/0/0.4000
    set vlans Svlan interface ge-0/0/1.4000
    set vlans v50 vlan-id 50

    2200-B

    set interfaces ge-0/0/0 unit 0 family inet address 30.30.30.2/24
    set interfaces vlan unit 100 family inet address 10.10.10.2/24
    set interfaces vlan unit 200 family inet address 20.20.20.2/24
    set vlans v100 vlan-id 100
    set vlans v100 interface ge-0/0/0.0
    set vlans v100 l3-interface vlan.100
    set vlans v200 vlan-id 200
    set vlans v200 interface ge-0/0/0.0
    set vlans v200 l3-interface vlan.200

    Thanks

    Partha



  • 3.  RE: QinQ QFX and EX

    Posted 06-17-2017 20:12

    Hi Partha,

     

    thanks for you quick response.

     

    I have validated and it seems that I have the same configuration, but it is still not working.  However I have one additional element in my scenario: a EX4550 acting as P that connects both PE, (you EX3300 and your QFX5100).

     

    In my case, this EX4550  only has two Aggregated ethernet configured as family ethernet port mode trunk.  So, if you see my configuration, this EX4550x1 is getting the S-vlan from one AE and passing it to another AE that is connected to the QFX.

     

    So i have this:  CE --> PE --->P ---> PE ---> CE

     

    Do I need to set anything special on the P Switch in order to see the mac-address on the QFX (PE). Per my revision, it seems that the P is passing the frames as standard dot1q frames and not as QinQ frames.

     

    Thanks

    Ezequiel

     

     



  • 4.  RE: QinQ QFX and EX

    Posted 06-20-2017 19:08

    Hi,

     

    I finally updated the JUNOS to the latest version and it worked fine (using your configuration)

     

    Thank you for your help 

    Ezequiel