Switching

Expand all | Collapse all

vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

  • 1.  vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

    Posted 02-02-2017 02:47

    Hi !

     

    Ther are some info on installing the vQFX10k , this one was helpful for me

     

    vQFX 10k Testlab on ESX 6.0 / 6.

     

    (NOTE that the RE needs a lot of memory if you add interfaces, I use 6GB/RE)

     

    but on ESX/ESXi you also need to set the correct mac-adresses (at least for all interfaces starting with xe-0/0/1, the xe-0/0/0 worked for me without setting the correct mac-adress))

     

    em3 to xe-0/0/0

    em4 to xe-0/0/1

    .....

    I have written a procedure for the vMX and adapted it for the vQFX which does this automatically on each commit

     

    The script sets the correct mac address on any configured XE interface  ( taken from the corresponding em(+3) interface,.

    • the mac address is visible under current address in show interface
    • Only if there is a mac adress set in the configuration, that one will be overwritten with the correct one.
    • If the interface belongs to an ae-set, then there will be no mac adress set, as the mac-address is set by the ae
    • if the config contains an interface without a corresponding em-interface , it signals an error on commit

     

    the procedure is attached... < EDIT notice: corrected slax script, as the gigether-options are called ether-options on QFX10k>

     

    Installation on RE

     

    > file copy  <location>/set-em-mac-to-xe-ae-vQFX.slax /var/db/scripts/commit/

     

    >edit

    # set system scripts commit allow-transients

    # set system scripts commit file set-em-mac-to-xe-ae-vQFX.slax

    #  commit

     

    Hope that helps to  install vQFx10k on ESXi, I assume that the mac-seting is also needed on VMware Workstation but I have not tested it.

     

    Another hint: there are a bunch of et,xe... interfaces with DHCP in the startup-factory-default, clear them all before starting with your configuration.

    and yes independent of your ESXi physical interfaces the interfaces are 10gig XE interfaces.

     

    With best regards

     

    Alexander Marhold

    JNCI, JNCIP-DC,....



  • 2.  RE: vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

    Posted 02-02-2017 08:15

    Installing and Running vQFX on Vmware Workstation

     

    1. Take the virtualbox-version and expand the file 2 times with a zip-program (eg. 7zip)
    2. The pfe can be started by opening the box.ovf in VMware ( ignore first message regarding OVF check not passed, it starts with relaxed
    3. For the RE you need to

     Edit  box.ovf and rename it ( eg. to re-box)

    Replace

    <Disk ovf:capacity="4293628416"

                  with                        

    <Disk ovf:capacity="4096" ovf:capacityAllocationUnits="MegaBytes"

     

    (the reason for the necessary enlargement of the disk-capacity seems to be that the diskexpansion on VMware WS needs slightly more space than virtualbox)

     

    Then open the edited re-box.ovf in VMware WS

     

    regards

     

    Alexander



  • 3.  RE: vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

    Posted 07-06-2017 07:47
      |   view attached

    Hi Alexander,

     

    Thanks for your post. I tried to install the vqfx-RE and vqfx-pfe on the workstation. I was able to boot the RE but on the PFE I am getting the error "Inappropriate ioctl for device".  Please see attached screen shot. Let me know if I am missing something or any work around for this error.

     

    Thanks

    Devendra



  • 4.  RE: vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

    Posted 07-10-2017 18:51

    Alex and all

    i followd the intrsuctions and added the commit script but the xe- interfaces showed once and vanished .. Any ideas ? workaround to bring the xe-interfaces back online ?

     

    root@vQFX_01_RE1> show interfaces terse    
    Interface               Admin Link Proto    Local                 Remote
    gr-0/0/0                up    up
    bme0                    up    up
    bme0.0                  up    up   inet     128.0.0.1/2     
                                                128.0.0.4/2     
                                                128.0.0.16/2    
                                                128.0.0.63/2    
    cbp0                    up    up
    dsc                     up    up
    em0                     up    up
    em0.0                   up    up   inet     10.1.10.155/24  
    em1                     up    up
    em2                     up    up
    em2.32768               up    up   inet     192.168.1.2/24  
    em3                     up    up
    em3.0                   up    up   inet    
    em4                     up    up
    esi                     up    up
    gre                     up    up
    ipip                    up    up
    irb                     up    up
    lo0                     up    up
    lo0.0                   up    up   inet    
                                       inet6    fe80::250:560f:fc90:b9a1
    lo0.16385               up    up   inet    
    lsi                     up    up
    mtun                    up    up
    pimd                    up    up
    pime                    up    up
    pip0                    up    up
    tap                     up    up
    vme                     up    down
    vtep                    up    up



  • 5.  RE: vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

    Posted 03-14-2018 22:38

    Hi rtrabelsi,

    i am getting the same problem. did you manage to get your xe- interfaces? if yes, then please share your solution. Thanks

     

    Regards

    Badar



  • 6.  RE: vQFX10k 15.1X53-D60 on ESXi Installation and Running with up to 10 Interfaces

     
    Posted 03-17-2018 09:59

    Could you explain what you mean by setting the write MAC address.  My show interface are sowing MAC address for all xe interfaces on vmware, I am just not sure how to conenect vqfx's router via xe interfaces and be able to ping. I apriciate it f you could explain this to me.

     

    root@vqfx-re# run show interfaces xe-0/0/1
    Physical interface: xe-0/0/1, Enabled, Physical link is Up
    Interface index: 649, SNMP ifIndex: 512
    Link-level type: Ethernet, MTU: 1518, LAN-PHY mode, Speed: 10Gbps, Duplex: Full-Duplex, BPDU Error: None, Loop Detect PDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled,
    Source filtering: Disabled, Flow control: Disabled, Media type: Fiber
    Device flags : Present Running
    Interface flags: SNMP-Traps Internal: 0x4000
    CoS queues : 8 supported, 8 maximum usable queues
    Current address: 02:05:86:71:53:07, Hardware address: 02:05:86:71:53:07
    Last flapped : 2018-03-15 14:29:26 UTC (1d 22:20 ago)
    Input rate : 0 bps (0 pps)
    Output rate : 0 bps (0 pps)
    Active alarms : None
    Active defects : None
    Interface transmit statistics: Disabled