SRX

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-16-2021 08:43
    Hello,

    I would like to ask you about reccomended steps for upgrade from current version of JunOS 15.1X49-D150.2 on SRX300 to JTAC reccommended JunOS version 19.4R3-S1.3?

    Can I make that upgrade directly from JunOS 15.1X49-D150.2 to 19.4R3-S1.3? Or should I make a upgrade to some additional version?

    Thank you very much.

    Regards.

    Rostislav

    ------------------------------
    ROSTISLAV NOVAK
    ------------------------------


  • 2.  RE: upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-16-2021 11:21
    Hi Rostislav,

    From Junos 15.1X49 directly to 19.4R3 or 19.4R3 based Service Releases is supported for all SRX platforms (ISSU is not supported). Please refer https://kb.juniper.net/InfoCenter/index?page=content&id=KB36620&act=login for more details.




  • 3.  RE: upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-17-2021 02:36

    Another option is to perform an "Install Media" [LINK] procedure to fresh install Junos OS Software on the SRX device (requires the use of an install-media image of the target release) which does not have any requirements regarding previously installed Junos release.



    ------------------------------
    // Hector Fuentes
    ------------------------------



  • 4.  RE: upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-17-2021 05:34
    I tried to upgrade directly 15.1X49 directly to 19.4R3 SR, and I got the following error messages:

    root@vSRX_D150> ...d /var/tmp/junos-srxsme-19.4R3-S1.3.tgz no-validate

    Installing package '/var/tmp/junos-srxsme-19.4R3-S1.3.tgz' ...

    Verified junos-boot-srxsme-19.4R3-S1.3.tgz signed by PackageProductionECP256_2020 method ECDSA256+SHA256

    Verified junos-srxsme-19.4R3-S1.3-domestic signed by PackageProductionECP256_2020 method ECDSA256+SHA256

    ERROR: Unsupported platform srxtvp, use a non-srxsme package

    ERROR: junos-19.4R3-S1.3 fails requirements check

    Installation failed for package '/var/tmp/junos-srxsme-19.4R3-S1.3.tgz'



    ------------------------------
    ROSTISLAV NOVAK
    ------------------------------



  • 5.  RE: upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-17-2021 05:47
    Hi Rostislav,

    Based on hostname, looks like you are using vSRX. If yes, the image you selected to upgrade is not valid for vSRX. Please check which vSRX model you are running and download the image accordingly.
    Please refer this KB, to identify whether you are running vSRX or vSRX3.0 and image name for them.
    https://kb.juniper.net/InfoCenter/index?page=content&id=KB33572



  • 6.  RE: upgrade from JunOS 15.1X49-D150.2 to junos-19.4R3-S1.3

    Posted 06-17-2021 05:54
    yes, you are right...sorry, stupid human error:) I wanted to try test that direct upgrade at our lab on our VSRX and I didnt notice that I download JunOS for SRX 300, not for vSRX :) I will do...Thanks :)

    ------------------------------
    ROSTISLAV NOVAK
    ------------------------------