SRX

 View Only
last person joined: 17 hours ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.

DHCPV6, client etc, matching with ISP

  • 1.  DHCPV6, client etc, matching with ISP

    Posted 03-01-2021 02:28
    I need some advice on my ipv6 internet connection, you know,
    the one that is supposed to say "Internet" in the Windows
    interface status. That isnt all thats wrong but its the
    same issue im guessing. The DNS servers wont bind.

    The IP addresses DO bind. I.E. 2601:XXXX
    I have a /60 from the ISP and this doesnt
    include NA. It is PD only. This means that
    to get where I am I had to match some stuff.

    I want to know if anyone has more to say about
    matching than ive got here.

    The part that was important to me was the
    prefix in access -> address-assignment.

    The lo0.0 was important to, but blah, blah.

    Please comment on shortages of code and keep
    in mind matching stuff like i mentioned.

    I marked in red where im not getting link
    traffic that my irb.0 isnt reaching. That
    media bride is getting the IPs too.

    I realize i have mismatched Bridge and AP,
    but thats another subject. Both same
    manufacturer but different models.

    Picture is attached, with code.
    The code is the relevant parts only.






    system {
        name-server {
            XX.XX.XX.XX;
            XX.XX.XX.XX;
            XXXX:XXX:XXXX::X;
            XXXX:XXX:XXXX::X;
        }
    
    
            dhcp-local-server {
                dhcpv6 {
                    overrides {
                        rapid-commit;
                        process-inform {
                            pool pool-2;
                        }
                        delegated-pool pool-2;
                    }
                    group group-for-pooling {
                        interface sp-0/0/0.0 {
                            exclude;
                        }
                        interface irb.0;
                        interface lo0.0;
                    }
                }
                group jweb-default-group {
                    interface sp-0/0/0.0 {
                        exclude;
                    }
                    interface irb.0;
                    interface lo0.0;
                }
            }
    
    
    
        zones {
            security-zone Internal {
                interfaces {
                    irb.0 {
                        host-inbound-traffic {
                            system-services {
                                ping;
                                dhcp;
                                dhcpv6;
                                http;
                                https;
                                ssh;
                                telnet;
                            }
                        }
                    }
                }
            }
            security-zone Internet {
                interfaces {
                    ge-0/0/0.0 {
                        host-inbound-traffic {
                            system-services {
                                ping;
                                dhcp;
                                dhcpv6;
                            }
                        }
                    }
                }
            }
        }
    }
    
    
    
    interfaces {
        ge-0/0/0 {
            unit 0 {
                arp-resp restricted;
                proxy-arp restricted;
                family inet {
                    dhcp-client {
                        update-server;
                    }
                }
                family inet6 {
                    ndp-proxy {
                        interface-restricted;
                    }
                    dhcpv6-client {
                        client-type stateful;
                        client-ia-type ia-pd;
                        prefix-delegating {
                            preferred-prefix-length 60;
                            sub-prefix-length 64;
                        }
                        update-router-advertisement {
                            interface irb.0 {
                                other-stateful-configuration;
                                enable-recursive-dns-server-option;
                            }
                        }
                        client-identifier duid-type duid-llt;
                        req-option dns-server;
                        req-option domain;
                        update-server;
                    }
                }
            }
        }
    
        irb {
            unit 0 {
                proxy-arp restricted;
                family inet {
                    address 192.168.1.1/24;
                }
                family inet6 {
                    ndp-proxy {
                        interface-restricted;
                    }
                    address fe80::0/64 {
                        eui-64;
                    }
                }
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 127.0.0.1/32 {
                        primary;
                        preferred;
                    }
                    address 10.0.0.254/32 {
                        primary;
                        preferred;
                    }
                }
                family inet6 {
                    ndp-proxy {
                        interface-restricted;
                    }
                    address ::1/128 {
                        primary;
                        preferred;
                    }
                    address 2601:1::1/64 {
                        preferred;
                    }
                    address fe80::0/64 {
                        eui-64;
                    }
                }
            }
        }
    }
    
    
    protocols {
        router-advertisement {
            interface ge-0/0/0.0 {
                managed-configuration;
                other-stateful-configuration;
                dns-server-address 2001:558:feed::1;
                dns-server-address 2001:558:feed::2;
                prefix 2601:204::0/60;
                prefix 2601:204::0/64
                prefix fe80::XXXXXXX/64;
            }
            interface lo0.0 {
                no-managed-configuration;
                no-other-stateful-configuration;
                dns-server-address 2001:558:feed::1;
                dns-server-address 2001:558:feed::2;
                prefix 0::1/128;
                prefix 2601:204::0/60;
                prefix 2601:204::0/64;
                prefix fe80::0/64;
            }
    
    
    
    access {
        address-assignment {
            neighbor-discovery-router-advertisement pool-2;
            pool jweb-default-pool {
                family inet {
                    network 192.168.1.0/24;
                    range jweb-default-range {
                        low 192.168.1.2;
                        high 192.168.1.254;
                    }
                    dhcp-attributes {
                        name-server {
                            XX.XX.XX.XX;
                            XX.XX.XX.XX;
                        }
                        router {
                            192.168.1.1;
                        }
                        netbios-node-type m-node;
                        propagate-settings irb.0;
                    }
                    host PC1 {
                        hardware-address XXXXXXXXX;
                        ip-address XXXXXXXXX;
                    }
                }
            }
            pool pool-2 {
                family inet6 {
                    prefix 2601:204::1/60;
                    dhcp-attributes {
                        propagate-settings ge-0/0/0.0;
                    }
                }
            }
        }
    }
    routing-instances {
        DHCP {
            system {
                services {
                    dhcp-local-server {
                        dhcpv6 {
                            overrides {
                                process-inform {
                                    pool pool-2;
                                }
                                delegated-pool pool-2;
                            }
                            group group1 {
                                interface sp-0/0/0.0 {
                                    exclude;
                                }
                                interface irb.0;
                                interface lo0.0;
                            }
                        }
                        group jweb-default-group {
                            interface sp-0/0/0.0 {
                                exclude;
                            }
                            interface irb.0;
                            interface lo0.0;
                        }
                    }
                }
            }
            access {
                address-assignment {
                    neighbor-discovery-router-advertisement pool-2;
                    pool jweb-default-pool {
                        family inet {
                            network 192.168.1.0/24;
                            range jweb-default-range {
                                low 192.168.1.2;
                                high 192.168.1.254;
                            }
                            dhcp-attributes {
                                name-server {
                                    XX.XX.XX.XX;
                                    XX.XX.XX.XX;
                                }
                                router {
                                    192.168.1.1;
                                }
                                netbios-node-type m-node;
                                propagate-settings irb;
                            }
                            host PC1 {
                                hardware-address XXXXXXXX;
                                ip-address XXXXXXXX;
                            }
                        }
                    }
                    pool pool-2 {
                        family inet6 {
                            prefix 2601:204::1/60;
                            dhcp-attributes {
                                propagate-settings ge-0/0/0;
                            }
                        }
                    }
                }
            }
        }
    }​


    ------------------------------
    Adrian Aguinaga
    B.S.C.M. I.T.T. Tech
    (Construction Management)
    A.A.S. I.T.T. Tech
    (Drafting & Design)
    ------------------------------