SRX

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



SRX345 not sending jflow data to the collector

  • 1.  SRX345 not sending jflow data to the collector

    Posted 14 days ago
    Hi guys, 

    I'm trying to configure our SRX345 cluster to send jflow data to a collector (Scrutinizer). The collector has the IP 10.101.80.20, one of the networks connected directly to the SRX345 cluster, it is the management network. But for some reason, the GWs are not sending any jflow data. This is the config we've put in place:

    admin.fw@MANBGFW01> show configuration services 
    flow-monitoring {
        version9 {
            template ipv4-test {
                ipv4-template;
            }
            template IPV4-JFLOW-TEMPLATE {
                ipv4-template;
            }
        }
    }
    
    admin.fw@MANBGFW01> show configuration interfaces
    
    reth0 {
        description VLAN_Office;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                sampling {
                    input;
                }
                address x.x.x.x/24 {
                }
            }
        }
    }
    reth1 {
        description VLAN_DEVS-Admins;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                filter {
                    input SBR;
                }
                sampling {
                    input;
                }
                address x.x.x.x/24;
            }
        }
    }
    reth2 {
        description VLAN_MGMT;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                filter {
                    input SBR;
                }
                sampling {
                    input;
                    output;
                }
                address 10.101.80.254/24;
            }
        }
    }
    reth3 {
        description VLAN_SSLVPN;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                filter {
                    input SBR;
                }
                sampling {
                    input;
                }
                address x.x.x.x/23;
            }
        }
    }
    reth4 {                                 
        description VLAN_WiFI-Dirty;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                filter {
                    input SBR;
                }
                sampling {
                    input;
                }
                address x.x.x.x/23;
            }
        }
    }
    reth5 {
        description VLAN_Internet;
        redundant-ether-options {
            redundancy-group 1;
        }
        unit 0 {
            family inet {
                sampling {
                    input;
                    output;
                }
                address x.x.x.x/30;
                address y.y.y.y/28 {
                    primary;
                    preferred;
                }
            }
        }
    }
    
    
    admin.fw@MANBGFW01> show configuration forwarding-options 
    sampling {
        input {
            rate 100;
            run-length 0;
        }
        family inet {
            output {
                flow-server 10.101.80.20 {
                    port 2055;
                    version9 {
                        template {
                            IPV4-JFLOW-TEMPLATE;
                        }
                   }
                }
                inline-jflow {
                    source-address 10.101.80.254;
                }
            }
        }
    }
    
    ​

    Any idea why it is not working?

    Thanks!