SRX

Expand all | Collapse all

SRX300 with Draytek 130 PPPoE SessionDown

Jump to Best Answer
  • 1.  SRX300 with Draytek 130 PPPoE SessionDown

    Posted 07-23-2018 03:26

    Hi All,

    Need some help with getting an external modem (Draytek Vigor 130) to work via PPoE on an ADSL connection. I can get this to work with zero issues on a Cisco 881 without issue. Any ideas?

     

    Config used is below:

     

    root@Data_Test# show interfaces ge-0/0/5
    unit 0 {
    encapsulation ppp-over-ether;
    }

    root@Data_Test# show interfaces pp0

    unit 0 {
    ppp-options {
    chap {
    default-chap-secret "$9$INvRyevMLNVsfTyeWxVb.mf5Q3"; ## SECRET-DATA
    local-name "RADIUS-USERNAME-REDACTED";
    passive;
    }
    }
    pppoe-options {
    underlying-interface ge-0/0/5.0;
    idle-timeout 0;
    auto-reconnect 1;
    client;
    }
    family inet {
    mtu 1492;
    negotiate-address;
    }
    }

    root@Data_Test# show security zones
    security-zone untrust {
    screen untrust-screen;
    host-inbound-traffic {
    system-services {
    all;
    }
    protocols {
    all;
    }
    }
    interfaces {
    ge-0/0/0.0;
    pp0.0;
    ge-0/0/5.0;
    }
    }

    root@Data_Test> show ppp summary
    Interface Session type Session phase Session flags
    pp0.0 PPP Disabled

    }

    root@Data_Test> show pppoe statistics
    Active PPPoE sessions: 0
    PacketType Sent Received
    PADI 16999 0
    PADO 0 0
    PADR 0 0
    PADS 0 0
    PADT 0 0
    Service name error 0 0
    AC system error 0 0
    Generic error 0 0
    Malformed packets 0 0
    Unknown packets 0 0
    Timeout
    PADI 2819
    PADO 0
    PADR 0
    Receive Error Counters
    PADI 0
    PADO 0
    PADR 0
    PADS 0

    }

    root@Data_Test> show pppoe interfaces
    pp0.0 Index 76
    State: PADI sent, Session ID: None,
    Service name: None,
    Session AC name: None, Configured AC name: None,
    Remote MAC address: 00:00:00:00:00:00,
    Auto-reconnect timeout: 1 seconds, Idle timeout: Never,
    Underlying interface: ge-0/0/5.0 Index 74
    Ignore End-of-List tag: Disable
    PPP-Max-Payload tag: 1492

    }

    root@Data_Test> show interfaces pp0
    Physical interface: pp0 , Enabled, Physical link is Up
    Interface index: 129, SNMP ifIndex: 501
    Type: PPPoE, Link-level type: PPPoE, MTU: 1532
    Device flags : Present Running
    Interface flags: Point-To-Point SNMP-Traps
    Link type : Full-Duplex
    Link flags : None
    Input rate : 0 bps (0 pps)
    Output rate : 0 bps (0 pps)

    Logical interface pp0.0 (Index 76) (SNMP ifIndex 544)
    Flags: Hardware-Down Up Point-To-Point SNMP-Traps 0x0 Encapsulation: PPPoE
    PPPoE:
    State: SessionDown, Session ID: None,
    Configured AC name: None, Service name: None,
    Auto-reconnect timeout: 1 seconds, Idle timeout: Never,
    Underlying interface: ge-0/0/5.0 (Index 74)
    Ignore End-Of-List tag: Disable
    PPP-Max-Payload tag: 1492
    Input packets : 0
    Output packets: 0
    Keepalive settings: Interval 10 seconds, Up-count 1, Down-count 3
    Keepalive: Input: 0 (never), Output: 0 (never)
    LCP state: Not-configured
    NCP state: inet: Not-configured, inet6: Not-configured, iso: Not-configured, mpls:
    Not-configured
    CHAP state: Closed
    PAP state: Closed
    Security: Zone: untrust
    Allowed host-inbound traffic : bootp bfd bgp dns dvmrp igmp ldp msdp nhrp
    ospf pgm pim rip router-discovery rsvp sap vrrp dhcp finger ftp tftp
    ident-reset http https ike netconf ping reverse-telnet reverse-ssh rlogin
    rpm rsh snmp snmp-trap ssh telnet traceroute xnm-clear-text xnm-ssl lsping
    ntp sip r2cp webapi-clear-text webapi-ssl tcp-encap
    Protocol inet, MTU: 1492
    Flags: Sendbcast-pkt-to-re, Protocol-Down, User-MTU, Negotiate-Address



  • 2.  RE: SRX300 with Draytek 130 PPPoE SessionDown

     
    Posted 07-23-2018 20:38


  • 3.  RE: SRX300 with Draytek 130 PPPoE SessionDown
    Best Answer

    Posted 07-25-2018 04:53

    As it turns out, the command "set protocols l2-learning global-mode switching" seemed to interfere with the PPPoE running properly. All resolved now, thanks.