SRX

Expand all | Collapse all

SRX340 interface issue

Jump to Best Answer
  • 1.  SRX340 interface issue

     
    Posted 08-02-2018 05:24

    Hi all,

     

    I am testing some Juniper devices for possible use as NTE for the Ethernet Core.

     

    I configured and tested the SRX300 and that works fine. I am now configuring an SRX340 and have hit a problem.....

     

    I have configured the following for Interface ge-0/0/5:

    set security zones security-zone trust interfaces irb.10
    set interfaces ge-0/0/5 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ge-0/0/5 unit 0 family ethernet-switching vlan members v10

    set interfaces irb unit 10 family inet address 100.100.100.2/30

    set vlans v10 vlan-id 10
    set vlans v10 l3-interface irb.10

     

    Okay. So, that is the configuration, but the error is even more strange.

     

    The cat5e cable connected to port 5 connects to our Core MX router. Hence the requirement of the VLAN. When I physically connect this canle the physical layer Green lights do not come on. In fact, it does not matter what port I attach this cable to, the port lights do not come on. When I attached this same cable back to the SRX300 it all worked fine. So I know there is nothing wrong with the cable and the config is the same as the SRX300.

     

    Anyone got any ideas with this?

     

     

     

     



  • 2.  RE: SRX340 interface issue

     
    Posted 08-02-2018 06:33

    How strange.

     

    I'm hoping someone can help with this, or it's a bug.

     

    Update:

    The last 8 ports on the SRX340 are sfp. So, I found a copper sfp and tried this and the green light came on immediately and I had connectivity to the core. I noticed this port (ge-0/0/15) was running at 100mbps on full-duplex instead of 1000mbps. So, as a test, I set ge-0/0/5 to 100 / FULL. I connected the cat5e cable and still, no Green light. This cannot possibly be the way that this SRX operates? There must be something inherently built in to make some ports 100m and some 1000mbps.

     

    Please can a Juniper representative look into the issue please?

     

    Thanks



  • 3.  RE: SRX340 interface issue
    Best Answer

     
    Posted 08-02-2018 06:49

    Okay. It seems the sfp ports, although they are ge ports, can autosense to 100mbps. The other ge ports cannot.

     

    On the SRX300 they are all inbuilt copper ports yet port ge-0/0/5 can autosense to 100mbps yet the other ports cannot.

     

    I understand that this means 1 port for WAN usage if presented with a 100m uplink, but should they not all autosense.

    This going to cause some problems for the customers.

     

    Thanks. Juniper reps, please look into this.

     

     



  • 4.  RE: SRX340 interface issue

     
    Posted 08-02-2018 07:33

    What versions are you running on the 300 and 340?



  • 5.  RE: SRX340 interface issue

     
    Posted 08-02-2018 08:21

    Hostname: ethernet-test-340
    Model: srx340
    Junos: 15.1X49-D140.2
    JUNOS Software Release [15.1X49-D140.2]



  • 6.  RE: SRX340 interface issue

     
    Posted 08-02-2018 09:14
    Well that rules out any early version bugs. What is the interface config on the mx? Is it hard coded to 100M?