SRX

Expand all | Collapse all

SRX110 VDSL Configuration pp0.0 down inet

Jump to Best Answer
  • 1.  SRX110 VDSL Configuration pp0.0 down inet

    Posted 04-18-2018 13:37

    Hi,

     

    I'm new to configuring Juniper products, I know my way around Cisco products reasonably well, certainly not a pro but not a beginner. 

     

    I've brought an SRX110H-VA to get into Juniper and I'm attempting to replace my Cisco router on my VDSL line with the SRX.

     

    I've followed the VDSL configuration guide for what I believe is the correct settings:

    https://www.juniper.net/documentation/en_US/junos/topics/example/vdsl2-pim-security-interface-configuring.html

    CHAP authentication and negotiated IP.  The Cisco and talktalk supplied router both use chap and negotiate the IP address so I believe this is correct.

     

    However when I use the show interfaces terse command the pp0.0 interface is showing as "up down inet"

    pp0.0                   up    down inet

     

    Can anyone point me in the right kind of direction?

     

    Below are the vdsp commands I've configured:

    pt-1/0/0 {
    vdsl-options {
    vdsl-profile auto;
    }
    unit 0 {
    encapsulation ppp-over-ether;
    }
    }
    pp0 {
    unit 0 {
    ppp-options {
    chap {
    default-chap-secret "xxxxxxxxxxxxxxxxxxxxx"; ## SECRET-DATA
    local-name "xxx@yyy.com";
    }
    }
    pppoe-options {
    underlying-interface pt-1/0/0.0;
    auto-reconnect 10;
    client;
    }
    family inet {
    negotiate-address;
    }
    }
    }

     

    Any assistance would be greatly appreciated 🙂

     

    Many Thanks,

    Tom



  • 2.  RE: SRX110 VDSL Configuration pp0.0 down inet

     
    Posted 04-19-2018 04:27
    Can you share output for “root@srx> monitor traffic interface pt-1/0/0 no-resolve”


  • 3.  RE: SRX110 VDSL Configuration pp0.0 down inet

    Posted 04-19-2018 12:08

    Hi,

     

    Many Thanks for your response.

     

    There's no a lot of activity when I run this command:

    hostname@srx# ...erface pt-1/0/0 no-resolve
    verbose output suppressed, use <detail> or <extensive> for full protocol decode
    Address resolution is OFF.
    Listening on pt-1/0/0, capture size 96 bytes

    19:06:42.619406 Out PPPoE PADI [Host-Uniq UTF8] [Service-Name]
    19:06:45.654042 Out PPPoE PADI [Host-Uniq UTF8] [Service-Name]
    19:06:50.711805 Out PPPoE PADI [Host-Uniq UTF8] [Service-Name]

     

    Shall I run with the detail or extensive outputs?

     

    I did find VDSL configs on various Juniper documents with an Access profile. Would this be required?

     

    Many Thanks,

     

    Tom



  • 4.  RE: SRX110 VDSL Configuration pp0.0 down inet

    Posted 04-19-2018 12:39

    Hi,

     

    Looking into this further I think it's because I'm not tagging the vlan on the interface.

     

    When I configure my cisco device I have to specify the vlan tagging, 101 in my case.

     

    When I try and set this on the srx pt-1/0/0 interface it's saying I can't configure it. It complains about vlan tagging only being able to configure tagging on an ethernet interface:

    [edit interfaces pt-1/0/0]
    user@SRX110H-VA-House# set vlan-tagging

    [edit interfaces pt-1/0/0]
    user@SRX110H-VA-House# commit
    [edit interfaces]
    'pt-1/0/0'
    INTERFACES_TYPE_VLAN_TAGGING: vlan tagging can only be specified on ethernet interfaces
    error: configuration check-out failed

     

    Any ideas how I configure vlan tagging on a VDSL interface?

     

    Thanks,

    Tom



  • 5.  RE: SRX110 VDSL Configuration pp0.0 down inet
    Best Answer

    Posted 04-20-2018 13:19

    Hi,

     

    I've figured this one out 🙂 I needed to add vlan tagging onto the vdsl interface.  I ran into issues with this in my last post, and this was because I was running JunOS 11.x and  vlan tagging is not supported until release 12.1. 

     

    As soon as I upgraded the software bingo! so now I have a fully working firewall terminating my vdsl broadband.

     

    I wanted to post the solution in case anyone else bumps into this issue too.

    Regards,

    Tom