SRX

Expand all | Collapse all

DHCP not working [Juniper SRX300]

Jump to Best Answer
  • 1.  DHCP not working [Juniper SRX300]

    Posted 10-18-2018 09:14

    Hello,

     

    Everything is OK but my DHCP is not working.

    If I put fixed IPs into machines they work normally, if I let DHCP on so the computers get APIPA addresses.

     

    I am not a Juniper Expert so If somoene can help me I will paste down my CLI lines.

    Note that I am using a SRX300 and I already restarted the DHCP services.

     

        zones {
            security-zone Internal {
                host-inbound-traffic {
                    system-services {
                        http;
                        https;
                        ping;
                        dhcp;
                    }
                }
                interfaces {
                    ge-0/0/5.0 {
                        host-inbound-traffic {
                            system-services {
                                ping;
                                dhcp;
                                http;
                                https;
                                ssh;
                                telnet;
                            }
                        }
                    }
                    ge-0/0/1.0 {
                        host-inbound-traffic {
                            system-services {
                                ping;
                                snmp;
                                http;
                                https;
                                ssh;
                                telnet;
                            }
                        }
                    }
                }
            }
            security-zone Internet {
                host-inbound-traffic {
                    system-services {
                        ping;
                        http;
                        https;
                        ssh;
                        telnet;
                    }
                }
                interfaces {
                    st0.0;
                    ge-0/0/0.0;
                }
            }
            security-zone internal;
        }
    }
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family inet {
                    address 187.32.128.193/27;
                }
            }
        }
        ge-0/0/1 {
            unit 0 {
                family inet {
                    address 10.196.136.1/24;
                }
            }
        }
        ge-0/0/5 {
            unit 0 {
                family inet {
                    address 192.168.1.1/24;
                }
            }
        }
        st0 {
            unit 0 {
                family inet;
                family inet6;
            }
        }
    }
    routing-options {
        static {
            route 10.0.0.0/8 next-hop st0.0;
            route 0.0.0.0/0 next-hop 187.32.128.222;
        }
    }
    protocols {
        l2-learning {
            global-mode switching;
        }
    }
    access {
        address-assignment {
            pool rotem_pool {
                family inet {
                    network 10.196.136.0/24;
                    range rotem_pool {
                        low 10.196.136.50;
                        high 10.196.136.220;
                    }
                    dhcp-attributes {
                        name-server {
                            10.196.24.31;
                        }
                        router {
                            10.196.136.1;
                        }
                    }
                }
            }
        }
    }

     



  • 2.  RE: DHCP not working [Juniper SRX300]

    Posted 10-18-2018 11:20
    You're missing the dhcp and bootb (don't sure which one of two) in the [security zones security-zone Internal interface ge-0/0/1.0 host-inbound-traffic system-services]


  • 3.  RE: DHCP not working [Juniper SRX300]

    Posted 10-18-2018 11:45

    And how can I fix it?

    As I told I am not Juniper expert, if possible give me the commands.

     

    Kind regards.



  • 4.  RE: DHCP not working [Juniper SRX300]
    Best Answer

    Posted 10-18-2018 12:11

    set security zones security-zone Internal interfaces ge-0/0/1.0 host-inbound-traffic system-services dhcp



  • 5.  RE: DHCP not working [Juniper SRX300]

    Posted 10-18-2018 12:48

    You are a God.

     

    Thank you.