SRX

Expand all | Collapse all

Can't root login from TTY console

Jump to Best Answer
  • 1.  Can't root login from TTY console

    Posted 06-29-2020 21:48

    Greetings,

    We have a brand new SRX345 that was passed on from another department, that had some configs on it, but never used in production, the previous sysadmin left the company and now I'm trying to factory reset it...

     

    So I do the standard 15 second config reset to go back to factory defaults, but I can't access the MGMT port using 192.168.1.1, nor can I access 192.168.2.1 (configuring my workstation with the appropriate static IPs and subnets.)  So, I decide to console into it, get my console up and running, can see the boot loader running,  etc, but when I get to the login prompt and type root, nothing happens... I expect it to drop down to the cli but nothing, so I reboot, and try to get it via safe mode, but I can't because it doesn't respond to the space bar and bring up the command prompt before boot... the console isn't taking in any input so it seems.  So I look up the settings in the terminal emulator (using Termite, nothing, so I download a trial of Hyperterm, still no inputs.) So I try my laptop that I use to console into my EX switches when need be, but same thing. 

     

    Am I missing something here?  Or does this thing need an RMA?



  • 2.  RE: Can't root login from TTY console

     
    Posted 06-29-2020 23:02

    Hello , 

     

    Its possible that when you factory reset the configuration , the root permission did not take effect . Because if the device is running 17.1 or above its explicitly denied . So I suggest to try installing 15.1X49 image using loader upgrade : 

     

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/install-software-on-srx.html#id-installing-junos-os-on-srx-series-devices-from-the-boot-loader-using-a-usb-storage-device

     

    Try this , if this works , you can later upgrade the device to latest code . Does not seems to be HW issue as we are getting login prompt in console . 

     

     



  • 3.  RE: Can't root login from TTY console

    Posted 06-30-2020 09:15

    Thanks, Sam.

    The OS is 15.1X49-D140.2

    I don't know, maybe it's the console cable...  really stumped here.  It has a dual power supply, but only one is plugged in, could that be causing trouble for some strange reason?



  • 4.  RE: Can't root login from TTY console
    Best Answer

    Posted 06-30-2020 09:22

    Dang... it was the console cable...  OK, problem solved.