SRX

Expand all | Collapse all

SRX320 VDSL2 mPIM Physical link down

Jump to Best Answer
  • 1.  SRX320 VDSL2 mPIM Physical link down

    Posted 12-02-2019 08:04

    Hi,

     

    I'm installing and configuring a VDSL2 mPIM at a remote site. We need to setup the mPIM for ADSL. Both the ADSL line and config are new (this is a first install). Our technician at the remote site has installed the mPIM card and booted the SRX. He connected the port to the telco outlet. Although the interface is configured no LEDs are On or Blinking. Telco claims they have successfully delivered the ADSL connection. I need to determine if this is a problem with our connection from the Telco, a hardware problem or a misconfiguration. See several outputs of the SRX below. I would kindly ask to verify the config, give troubleshooting tips. Any help is appriciated.

     

    Thanks in advance for your help,

     

    Kind regards,

    Dimitry

     

     

    root@router>show chassis hardware   

    FPC 1 REV 09 750-064612 Serial number FPC PIC 0 1x VDSL2 mPIM (RoHS)

     

    root@router>show configuration interface 

    et interfaces at-1/0/0 encapsulation ethernet-over-atm
    set interfaces at-1/0/0 atm-options vpi 0
    set interfaces at-1/0/0 dsl-options operating-mode auto
    set interfaces at-1/0/0 unit 0 description "To Interconnect ADSL mPIM"
    set interfaces at-1/0/0 unit 0 encapsulation ether-over-atm-llc
    set interfaces at-1/0/0 unit 0 vci 0.35
    set interfaces at-1/0/0 unit 0 family inet address 10.10.10.2/30

     

    root@router> show interfaces at-1/0/0
    Physical interface: at-1/0/0, Enabled, Physical link is Down
    Interface index: 150, SNMP ifIndex: 536
    Link-level type: Ethernet-over-ATM, MTU: 1514, Clocking: Internal, ADSL mode, Speed: ADSL,
    Loopback: None
    Device flags : Present Running Down
    Link flags : None
    CoS queues : 8 supported, 8 maximum usable queues
    Current address: cc:e1:94:5a:78:2a
    Last flapped : 2019-10-15 12:32:53 CEST (6w6d 04:00 ago)
    Input rate : 0 bps (0 pps)
    Output rate : 0 bps (0 pps)
    ADSL alarms : None
    ADSL defects : None
    ADSL status:
    Modem status : Down
    DSL mode : Auto Annex A
    Last fail code: None
    Subfunction : 0x00
    Seconds in showtime : 0

     

    root@router>show interfaces terse

    at-1/0/0 up down
    at-1/0/0.0 up down inet 10.10.10.2/30

     



  • 2.  RE: SRX320 VDSL2 mPIM Physical link down

     
    Posted 12-02-2019 17:34

    You will also need a dialer interface.... if its VDSL you configure pt-1/0/0 and if its ADSL you configure at-1/0/0

     

    VDSL Example DSL and Dialer Interfaces:

    pt-1/0/0 {
        vlan-tagging;
        vdsl-options {
            vdsl-profile auto;
        }
        unit 0 {
            encapsulation ppp-over-ether;
            vlan-id 10;
        }
    }
    
    pp0 {
        unit 0 {
            ppp-options {
                pap {
                    local-name user1;
                    local-password "password1"; ## SECRET-DATA
                    passive;
                }
                lcp-max-conf-req 0;
            }
            pppoe-options {
                underlying-interface pt-1/0/0.0;
                idle-timeout 0;
                auto-reconnect 120;
                client;
            }
            no-keepalives;
            family inet {
                negotiate-address;
            }
        }
    }

    Zone: 

    security-zone untrust {
        interfaces {
            pp0.0 {
                host-inbound-traffic {
                    system-services {
                        ping;
                    }
                }
            }
        }
    }
    

    Routing-Options:

    static {
        route 0.0.0.0/0 {
            next-hop pp0.0;
            metric 0;
        }
    }
    

    NAT:

    source {
        rule-set trust-to-untrust {
            from zone trust;
            to zone untrust;
            rule destination-nat-rule {
                match {
                    destination-address [ 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 123.100.102.161/29 ];
                }
                then {
                    source-nat {
                        off;
                    }
                }
            }
            rule source-nat-rule {
                match {
                    source-address 0.0.0.0/0;
                }
                then {
                    source-nat {
                        interface;
                    }
                }
            }
        }
    }
    

     



  • 3.  RE: SRX320 VDSL2 mPIM Physical link down

    Posted 12-03-2019 03:19

    Hi Dawid,

     

    Thank you for your reply.

     

    This isn't an internetconnection but a Ethernet-circuit at Layer2 to our main-office. Is the dailer interface also nesessary for this type of connection?

     

    Do you expert the interface go to UP state when the cable of the Telco is connected with dsl-option operation-mode auto enabled? Or does this require the dailer interface?



  • 4.  RE: SRX320 VDSL2 mPIM Physical link down
    Best Answer

    Posted 12-23-2019 01:37

    Issue solved.

     

    The telco did make some mistakes delivering the line. There was actually no signal and therefor no sync. They needed 2 more appointments to fix the isssue. The config for the mPim VDSL card was correct and remained unchanged.

     

    root@router> show configuration interfaces at-1/0/0

    encapsulation ethernet-over-atm;

    atm-options {

        vpi 0;

    }

    dsl-options {

        operating-mode auto;

    }

    unit 0 {

        description "To Interconnect ADSL mPIM";

        encapsulation ether-over-atm-llc;

        vci 0.35;

        family inet {

            address 10.10.10.2/30;

        }

    }