SRX

Expand all | Collapse all

Cannot reset root password

  • 1.  Cannot reset root password

    Posted 10-05-2017 11:49

    I'm trying to run the root password reset and get through all the steps but the system will still not login me in with the new password. It just drops me back to the login: prompt. If I give it an intentional bad password it will tell me the login is incorrect so it's recognizing the new password but not allowing me into the CLI. This is running on a SRX 110 running 12.1X44-D30 (I'm guessing on the software since I can't login to the machine but it's a good guess)

     

    Snap 2017-10-05 at 11.47.30.png



  • 2.  RE: Cannot reset root password

    Posted 10-05-2017 11:56

    Hi

    ever tried it with root and pressing return when the password prompt is shown ?

    Amnesiac means nothing defined,

    so you maybe did not suceed setting a root password

     

    regards

     

    alexander



  • 3.  RE: Cannot reset root password

    Posted 10-05-2017 11:58

    Just tried root with no password and it came back with "Login Incorrect Amnesia (ttyu0)

     



  • 4.  RE: Cannot reset root password

     
    Posted 10-05-2017 19:14

    do you have "authentication-order" configured? pointing to radius/tacacs or something like that?



  • 5.  RE: Cannot reset root password

    Posted 10-07-2017 08:29

    Looks like you have factory reset but maybe something still holding the password? Anyway, try the process for recovering root password:

     

    https://www.juniper.net/documentation/en_US/junos/topics/task/operational/security-root-password-srx-series-device-recovering.html

     

    The trick is getting into single user mode as outlined in the instructions.



  • 6.  RE: Cannot reset root password

    Posted 10-20-2017 12:40

    yeah I already tried that. Still no luck. I go into recovery mode, reset the password and then reboot and nothing works. When I try and intentionally login with a bad password, I get a "login incorrect" error message. When I login with the correct password, I don't get that message. It just drops back to a login prompt. 



  • 7.  RE: Cannot reset root password

    Posted 10-20-2017 13:07

    I think I ran into that once before too. If I recall, I believe it was that you can reset the password to pretty much anything that you want but if that password doesn't meet the system requirements for length and/or complexity then it doesn't let you log on with it. It will not give you an error message either though. Maybe try setting a pretty strong password through the single boot recovery method and see if that helps?



  • 8.  RE: Cannot reset root password

    Posted 10-23-2017 02:14

    Since you are any doing the reboot and not able to login with new password..

    You may use reset button to factory reset SRX and reboot the boxes to recover.

     

    However i do assume that you are already having the backup of the existing configuration.

     

    Pl follow the instructions carefully for using reset button.

     

    Using the Reset Config Button

    Note: The Reset Config button is available only on the SRX Branch and J-Series devices. 

    You can use the Reset Config button on the front panel of the SRX and J-Series device to reset the device to its factory default configuration. The Reset Config button is recessed to prevent it from being pressed accidentally; so you need to insert a small probe (for example, a straightened paper clip) to press the button.

    Caution: If you use the Reset Config button to reset the device to its factory default configuration, all the configuration files, including the rescue configuration and backup configurations, will be deleted. 

    For instructions, refer to the following links:

     

    https://www.juniper.net/documentation/en_US/release-independent/junos/topics/task/operational/reset-config-button-srx110-using.html

     

    Also post resetting password, paste your config again on SRX except root password snippet..



  • 9.  RE: Cannot reset root password

    Posted 10-23-2017 00:04

    Can you try the procedure defined here (though it is for MX80 but should work on SRX too):

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/authentication-root-password-recovering-mx80.html

     

    Adjust the parameters per your config file i.e. line number.

     

     



  • 10.  RE: Cannot reset root password

     
    Posted 10-25-2017 23:46
    Did you have any password rules like "minimum changes" or "length" and have a "protect" statement on those rules?

    Anand