SRX

Expand all | Collapse all

Help with Configuring SNMP

Jump to Best Answer
  • 1.  Help with Configuring SNMP

    Posted 09-01-2017 14:18

    Hey guys-

     Im brand spankin' new to JunOS and trying to set up SNMP.  Its pretty basic, I know, but I believe something with the security zones may be blocking it from being polled.  I searched for and found a ton of information on how to troubleshoot it, but I havent had any luck.  This is my snmp config:

     

    name DeviceName;
    description Device;
    location CityTown;
    contact "Administrator";
    community SNMPv2 {
    authorization read-only;
    }

     

    We have an internal zone where smp is enabled and vlan.1 is assigned to:

     

    show security zones security-zone Internal host-inbound-traffic
    system-services {
    all;
    snmp;
    }

     

    However, when I send a get to the IP on vlan.1 it doesnt respond.

     

    Any help would be appreciated!

     

    Thanks.

     

     



  • 2.  RE: Help with Configuring SNMP

    Posted 09-01-2017 17:32
    Don't forget you community.


  • 3.  RE: Help with Configuring SNMP

     
    Posted 09-02-2017 22:11

    Hello,

     

    This link would be helpful for configuration purpose.

     

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB16545&actp=METADATA

     

    On vlan.1 interface, can you run following command when you are sending get to the vlan.1's IP address?

     

    * monitor traffic interface vlan.1 no-resolve.

     

    Security Zone configuration does look okay to me though.

     

    Regards,

     

    Rushi

     

     



  • 4.  RE: Help with Configuring SNMP

    Posted 09-02-2017 22:47

    I have to suspect that this is not the complete configuration of this zone:

    We have an internal zone where smp is enabled and vlan.1 is assigned to:

     

    show security zones security-zone Internal host-inbound-traffic
    system-services {
    all;
    snmp;
    }

     There is no interrface in the zone so SNMP would not work. Also do you have junos-host zone configured? Be sure to show the entire relevant configuration (sanitized if needs be) to get best help. The SNMP config is incomplete Where is config for the NMS etc. Can you show all of the SNMP configuration? And also can you reach rthe NMS from the SRX?


    @pseudoyams wrote:

    Hey guys-

     Im brand spankin' new to JunOS and trying to set up SNMP.  Its pretty basic, I know, but I believe something with the security zones may be blocking it from being polled.  I searched for and found a ton of information on how to troubleshoot it, but I havent had any luck.  This is my snmp config:

     

    name DeviceName;
    description Device;
    location CityTown;
    contact "Administrator";
    community SNMPv2 {
    authorization read-only;
    }

     

    We have an internal zone where smp is enabled and vlan.1 is assigned to:

     

    show security zones security-zone Internal host-inbound-traffic
    system-services {
    all;
    snmp;
    }

     

    However, when I send a get to the IP on vlan.1 it doesnt respond.

     

    Any help would be appreciated!

     

    Thanks.

     

     


     



  • 5.  RE: Help with Configuring SNMP
    Best Answer

    Posted 09-05-2017 06:28

    Thanks for the replies everyone.

     

     

    I had a whole different reply back but while I was gathering more information for this post I figured out the issue.

     

    What needed to be done was to add SNMP under the Internal zone, Host inbound traffic - Interface tab, select vlan.1 and under Interface services add SNMP.

     

    I had done a similar step prior to my original post, but under the Host inbound traffic - zone tab instead. Here is the final config of the zone:

     

    user@SRX01# show security zones security-zone Internal
    address-book {
        <removed>
    }
    host-inbound-traffic {
        system-services {
            all;
            snmp;
        }
    }
    interfaces {
        vlan.1 {
            host-inbound-traffic {
                system-services {
                    ping;
                    dhcp;
                    http;
                    https;
                    ssh;
                    telnet;
                    snmp;
                }
            }
        }
    }
    

    Thanks for everyones help!



  • 6.  RE: Help with Configuring SNMP

    Posted 09-04-2017 08:46
    You have to make sure you have the statements with ro and rw. Across the network.