SRX

 View Only
last person joined: yesterday 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  DHCP Issue being a client and server

    Posted 05-16-2014 10:35

    I'm trying to:

     

    Get a v4 address and a v6 address from my ISP

    Serve DHCP addresses to my internal zone

     

    Aparently I'm doing something either wrong or unsupported here. When I put in the system services dhcp configutation it says I have incompatabilities with my fe-0/0/0 interface being a dhcp client.

     

    Any suggestions?

     

    Thanks

     

     

    version 12.1X46-D15.3;
    system {
        services {
            ssh {
                protocol-version v2;
            }
            dhcp {
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    192.168.1.254;
                }
                pool 192.168.1.0/24 {
                    address-range low 192.168.1.100 high 192.168.1.149;
                }
            }
        }
    }
    interfaces {
        fe-0/0/0 {
            unit 0 {
                family inet {
                    ##
                    ## Warning: Incompatible with the dhcp server configured under 'system services dhcp'
                    ##
                    dhcp-client;
                }
                family inet6 {
                    ##
                    ## Warning: Incompatible with the dhcp server configured under 'system services dhcp'
                    ##
                    dhcpv6-client {
                        client-type statefull;
                        client-ia-type ia-pd;
                        rapid-commit;
                        update-router-advertisement {
                            interface vlan.0;
    ....

     



  • 2.  RE: DHCP Issue being a client and server

    Posted 05-16-2014 13:38

    I'd stop using the system services dhcp hierarchy and start using "set access address-assignment" for DHCP.  Check out my post here:

     

    http://forums.juniper.net/t5/SRX-Services-Gateway/DHCP-static-binding-not-working/m-p/240326#M29515



  • 3.  RE: DHCP Issue being a client and server

    Posted 05-18-2014 07:47

    Changing to set access address-assignment hierarchy worked great thanks!


    @peterbishop wrote:

    I'd stop using the system services dhcp hierarchy and start using "set access address-assignment" for DHCP.  Check out my post here:

     

    http://forums.juniper.net/t5/SRX-Services-Gateway/DHCP-static-binding-not-working/m-p/240326#M29515


     



  • 4.  RE: DHCP Issue being a client and server

    Posted 10-04-2018 21:13

    What is the ISP side interface is Dynamic ( DHCP) , I tried this new method because I want a specific host on my LAN pool to get the same IP everytime ( static binding) but I lost the IP on external interface ( in my case fe-0/0/7)

     

     

        pool Wired {

            family inet {

                network 172.24.10.0/24;

                range wired {

                    low 172.24.10.20;       

                    high 172.24.10.250;     

                }                           

                dhcp-attributes {           

                    name-server {           

                        75.75.75.75;        

                        172.24.10.1;        

                    }                       

                    router {                

                        172.24.10.1;        

                    }                       

                }                           

                host Macbook {              

                    hardware-address xx.xx.xx.xx;

                    ip-address 172.24.10.26;

                }   

                                   

    cq# show | display set                

    set interfaces fe-0/0/7 description "To Internet Modem"

    set interfaces fe-0/0/7 unit 0 family inet dhcp-client update-server

     



  • 5.  RE: DHCP Issue being a client and server

    Posted 10-04-2018 21:21

    I have the same issue, can anyone help with ISP as DHCP ( Comcast etc) 



  • 6.  RE: DHCP Issue being a client and server

    Posted 10-09-2018 11:25

    Guys any help, ISP side is Dynamic, what do you do in that case?



  • 7.  RE: DHCP Issue being a client and server

    Posted 10-09-2018 12:18

    Hi hayyankk,

     

    When you say that you have the same issue, you mean that you have both DHCP server and client configured and its not working? (thats the issue of this ppost) If not, maybe you could open a new forum post for your specific question/issue.

     

     



  • 8.  RE: DHCP Issue being a client and server

    Posted 05-17-2014 00:39

    set interfaces fe-0/0/0 unit 0 family inet dhcp

    set interfaces fe-0/0/0 unit 0 family inet6 dhcp

    set security zones security-zone untrust interfaces fe-0/0/0.0 host-inbound-traffic system-services dhcp

    Assuming that your fe-0/0/0 is connected to the  ISP and it is in the zone named untrust (put in relevant zone) Add additional services and protocols if required.