SRX

Expand all | Collapse all

ip ospf mtu ignore

  • 1.  ip ospf mtu ignore

    Posted 11-22-2012 03:18

    Hi Friends,

     

    Does anyone know if we can use opsf mtu ignore on SRXs?

     

    I could change the mtu of the interface using the following:

     

    root@SRX# set interfaces ge-0/0/0 mtu 1514                             <<<<this  will give you Protocol

     

    but this could indroduce performance issues on ther interface.



  • 2.  RE: ip ospf mtu ignore

    Posted 11-22-2012 03:30

     

    Look to the following. The protocol mtu is taken from the interface mtu, but you have to adjust this to the peer configuration.

     

     

    http://kb.juniper.net/InfoCenter/index?page=content&id=KB19382

     

     



  • 3.  RE: ip ospf mtu ignore

    Posted 11-28-2013 05:43

    Hi,

     

    Junos doenst support this feature yet. You may follow this KB-

     

    http://kb.juniper.net/InfoCenter/index?page=content&id=KB13137&actp=search&searchid=1245641476521

     

    Thanks,

    Rewanta

     

     

     



  • 4.  RE: ip ospf mtu ignore

    Posted 01-25-2020 01:45

    Hi,

     

    anyone can explain me the behaviour of JNOS while receiving  DBD Packet with MTU fiels Set to "0" 

    it will accept the packet or discard it.

     

    Thanks in advance.

    Sunil



  • 5.  RE: ip ospf mtu ignore

    Posted 01-26-2020 20:52

    Hello Sunil,

     

    OSPF uses IP MTU to peer neighborship and it cannot be set per interface. If the two interfaces have different MTU values configured, the OSPF between these interfaces will not come up (Default behaviour).

     

    The formula for calculating the IP MTU is as follows:
    IP MTU = Media MTU - Ethernet Header Length (14 bytes)
    For example, if the max-frame-size = 1514, then the IP MTU = 1500.

     

    However, the mismatch could occur if you are using VLANs:

    Ethernet header sizes:
    Standard = 14 bytes
    Vlan tagging = 14+4 = 18 Bytes
    Flexible-Vlan tagging = 18 + 4 = 22 Bytes

     

    In the Junos CLI, you can set the interface MTU in the range of below values.

    root@re0# set interfaces ge-2/2/2 mtu ?
    Possible completions:
    <mtu> Maximum transmit packet size (256..16000)

    I'm not very sure if there could be any scenario where the DBD MTU value can be set to 0 (as there would be an interface MTU value at peer end), however upto my understanding, if there is an OSPF MTU mismatch, the neighbourship wouldn't come up and it would be stuck in exstart/exchange state.

    This is also defined in RFC2328
    10.6. Receiving Database Description Packets
    .....
    If the Interface MTU field in the Database Description packet indicates an IP datagram size that is larger than the router can accept on the receiving interface without fragmentation, the Database Description packet is rejected.

    However the Cisco's command brings in proprietary behavior which is not suggested by RFC2328. Juniper does not support this behavior and does not have any special configuration to achieve such proprietry behavior.


    Thanks,
    Vishaal



  • 6.  RE: ip ospf mtu ignore

    Posted 02-02-2020 12:18

    HI Vishal, 

     

    Thaks for your responce.

     

    i was wondring, if you can share the behaviour of JunOS while receiving packet with MTU 0 in DBD. this is the default behaviour of Huawei devices.  OSPF-enabled Huawei device adds the MTU 0 in DD packets to be sent and does not check the MTUs in received DD packets.  i'm facing an issue where huawei is connected with Juniper and ospf peering is stuck in Exchange/Extart state.

     

    Sunil Kumar

     



  • 7.  RE: ip ospf mtu ignore

    Posted 02-09-2020 21:25

    Hello Sunil,

     

    The OSPF is stuck in Extstart/Exchange state, is a default behaviour as the MTU is mismatched. The OSPF adjaceny wouldn't come up. The huawei device has a slightly different behaviour when compared to the other vendor devices in this case. Any DD packet with MTU field set to 0 would be ignored by Junos. Junos by default checks for the MTU field as well to form the OSPF peering. In this case, the OSPF devices might be performing DD negotiation but cannot achieve DD synchronization. Here you would need to match the MTU values on both the interfaces.

     

    I have been through the Huawei OSPF config guide for more inputs and <ospf mtu-enable> command enables the interface to fill in the MTU value when sending DD packets.

     

    <HUAWEI> system-view
    [~HUAWEI] interface 10ge 1/17/1
    [~HUAWEI-10GE1/17/1] undo portswitch
    [*HUAWEI-10GE1/17/1] ospf mtu-enable

     

    Please try enabling the MTU on the huawei device and it should definetely bring up the OSPF peer (Provided the MTU value is same on both the devices)

     

    Thanks,

    Vishaal

     

    If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

     

     



  • 8.  RE: ip ospf mtu ignore

    Posted 02-10-2020 17:13

    hi Vishal,

     

    i had configured mtu 9192 on both huawei and juniper devices. after removing the mtu 9000 on both devices ( set to default value) ospf came up. i have'nt configured "ospf mtu-enable" on the interface.  still below points are not clear:-

     

    1. As per you "Any DD packet with MTU field set to 0 would be ignored by Junos" if this would be the case ospf  peering should'nt have came up after setting the interface mtu to default. 

     

    2. in the huawei and juniper  devices MTU calculation is as below :-

         Huawei= IP header + IP payload

          Juniper=MTU = Data payload + Destination MAC + Source MAC + Length    for example:- MTU = IP MTU +        14Bytes(Ethernet header).

    i have configured  mtu 9192 on both sides but  when i checked ospf  interface mtu on Junos using show ospf interface xxx detail   it was showing 14 less than configured value means 9178 (9192-14=9178) while on the huawei it was same as it was on the configuration. how complatiblity works in this case ?

     

    3.  As per the RFC "Interface MTU should be set to 0 in Database Description packets sent over virtual links".   

    is'nt it possible that JunOS is processing normal DBD packets (not over virtual links) with MTU field set to "0" normally (by ignoring the mtu field) ? because after changing mtu value to default ospf came up.

     

    Sunil Kumar