SRX

Expand all | Collapse all

question about vlan-tagging and reth

Jump to Best Answer
  • 1.  question about vlan-tagging and reth

    Posted 01-23-2012 07:42

    Hi,

     

    if you need vlan-tagging on redundant interfaces, where do you put the vlan-tagging configuration? in the physical interface config (ge-x/x/x) or the reth interface config?

     

    Thanks

    Sascha

     



  • 2.  RE: question about vlan-tagging and reth

    Posted 01-23-2012 07:45

    I might add: I figure I put this in the reth config because else I wouldn't be able to have more than 1 VLAN per reth. But I am not sure. 

     

    Thanks

     



  • 3.  RE: question about vlan-tagging and reth

    Posted 01-23-2012 07:58


  • 4.  RE: question about vlan-tagging and reth
    Best Answer

    Posted 01-23-2012 10:33

    It's configured under the reth configuration.

     

    reth3 {
        vlan-tagging;
        redundant-ether-options {
            redundancy-group 3;             
        }
        unit 182 {
            description "DMZ";
            vlan-id 182;
            family inet {
                address 1.1.1.2/24;
            }
        }
        unit 250 {
            description "Internal";
            vlan-id 250;
            family inet {
                address 192.168.1.1/24;
            }
        }
    }

     



  • 5.  RE: question about vlan-tagging and reth

    Posted 01-24-2012 04:58

    Thanks to both of you!



  • 6.  RE: question about vlan-tagging and reth

    Posted 06-27-2014 09:59

    Does this function supported in SRX650 & SRX1400 in cluster environment. As i need this feature very ungently



  • 7.  RE: question about vlan-tagging and reth

     
    Posted 06-27-2014 10:38

    yes. configuring vlans under reth interface applies to both branch and high-end platforms.

     

    Regards,

    Sam



  • 8.  RE: question about vlan-tagging and reth

    Posted 05-23-2017 19:57

    Hello guys,

    Would be most grateful if someone would explain the underlined part of the configuration below, and why its required.

     

    reth3 {

        vlan-tagging;

        redundant-ether-options {

            redundancy-group 3;             

        }

        unit 182 {

            description "DMZ";

            vlan-id 182;

            family inet {

                address 1.1.1.2/24;

            }

        }

        unit 250 {

            description "Internal";

            vlan-id 250;

            family inet {

                address 192.168.1.1/24;

            }

        }

    }

     

     

    Thanks

     



  • 9.  RE: question about vlan-tagging and reth

    Posted 11-06-2017 23:39

    reth3 {

        vlan-tagging;

        redundant-ether-options {

            redundancy-group 3;             

        }

    =============================

     

    This means that reth3 is part of RG group 3. This is part of chassis cluster configuration:

    For example:

    root@CORE-FW1# show chassis cluster | display set
    set chassis cluster control-link-recovery
    set chassis cluster reth-count 10
    set chassis cluster redundancy-group 3 node 0 priority 100
    set chassis cluster redundancy-group 3 node 1 priority 1
    set chassis cluster redundancy-group 3 preempt
    set chassis cluster redundancy-group 3 interface-monitor ge-0/0/2 weight 255
    set chassis cluster redundancy-group 0 node 0 priority 100
    set chassis cluster redundancy-group 0 node 1 priority 1

     

    Reth3 configuration example:
    set interfaces ge-0/0/2 gigether-options redundant-parent reth3
    set interfaces reth3 description XXXXX
    set interfaces reth3 vlan-tagging
    set interfaces reth3 redundant-ether-options redundancy-group 3
    set interfaces reth3 unit 10 vlan-id 10
    set interfaces reth3 unit 10 family inet address x.x.x.x
    set interfaces reth3 unit 30 vlan-id 30
    set interfaces reth3 unit 30 family inet address x.x.x.x

     

    Regards,
    Ankur Kher